Comprobar si una celda contiene texto (distinguiendo entre mayúsculas y minúsculas) – Excel – Office.com

Enlace:
Comprobar si una celda contiene texto (distinguiendo entre mayúsculas y minúsculas) – Excel – Office.com

Resumen:

Suponga que desea buscar un texto que comienza con un prefijo estándar de una empresa como, por ejemplo, ID_ o EMP-, y que dicho texto debe estar escrito en mayúsculas. Existen varias formas de comprobar si una celda incluye texto y si éste se encuentra en mayúsculas o minúsculas.

Comprobar si parte de una celda coincide con un texto específico

Para realizar esta tarea, utilice las funciones SI, ENCONTRAR y ESNUMERO.
 Nota   La función ENCONTRAR distingue entre mayúsculas y minúsculas.

1
2
3
A
Datos
Davolio
BD123
Fórmula Descripción (resultado)
=SI(ESNUMERO(ENCONTRAR(«v»;A2));» Correcto»; » Incorrecto») Comprueba si A2 contiene la letra v (Correcto)
=ESNUMERO(ENCONTRAR(«BD»;A3)) Comprueba si A3 contiene BD (VERDADERO)

La fórmula anterior utiliza los argumentos siguientes.


Fórmula para buscar texto

Fórmula para buscar texto

Llamada 1 buscar: lo que se desea comprobar.
Llamada 2 buscar_en: celda que contiene el texto que desea comprobar.
 
Espero que os resulte de utilidad.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.